Category Apps

YouTube Studio app now requires iOS 12 or later

The YouTube Studio app for iPhone now requires users to be on iOS 12 or later to continue receiving future updates. An update released earlier on Monday officially drops support for iOS 11. It also improves the real-time analytics cards…

Reddit For iOS Now Requires iOS 13 And Later

A recent update for the official Reddit app on iPhone and iPad drops support for iOS 12, meaning that users still running the older operating system will no longer be able to receive new features or security fixes with future…